Batwoman 1.07 Synopsis: “Tell Me The Truth”
01 Nov. 2019

Batwoman 1.07 Synopsis: “Tell Me The Truth”


We now have the episode synopsis for episode 1.07 of Batwoman, titled “Tell Me The Truth.” Check it out below.

BATWOMAN

“Tell Me the Truth” — (8:00-9:00 p.m. ET) (TV-14, DLV) (HDTV)

LIES AND LOYALTY – Kate (Ruby Rose) and Sophie (Meagan Tandy) must reconcile with their past as Kate questions just how much she can trust her former lover. Kate and Luke (Camrus Johnson) have an encounter with an old friend. Mary (Nicole Kang) grapples with the fate of the Kane family as Catherine (Elizabeth Anweis) seeks Jacob’s (Dougray Scott) help. Alice (Rachel Skarsten) and a new cohort are in on yet another nefarious plan, but her motives are more than they seem. Michael Allowitz directed the episode written by Caroline Dries and Natalie Abrams (#107). Original airdate 11/17/2019.

Catch Batwoman Sunday nights at 8/7c on the CW!

Find Batwoman Podcast On:

Social Media: Facebook  @BatwomanPodcast  Instagram

Subscribe: Apple Podcasts  Stitcher Radio – YouTube – DC TV Podcasts

Contact: batwomanpodcast@gmail.com

Support: TeePublic Store

About the author

Tags

Related posts

Batwoman Podcast Season 1 – Episodes 11/12: “An Un-Birthday Present”/”Take Your Choice”
Batwoman Podcast Season 1 – Episodes 11/12: “An Un-Birthday Present”/”Take Your Choice”
February 18, 2020 - 0 comment
Batwoman Podcast Season 1- Episode 10: “How Queer Everything Is Today!”
Batwoman Podcast Season 1- Episode 10: “How Queer Everything Is Today!”
January 26, 2020 - 0 comment
Batwoman Podcast Season 1 – Episode 9.5: “Crisis on Infinite Earths” (Part 4,5) – Podcast Crossover
Batwoman Podcast Season 1 – Episode 9.5: “Crisis on Infinite Earths” (Part 4,5) – Podcast Crossover
January 18, 2020 - 0 comment
Batwoman Podcast Season 1 – Episode 9: “Crisis on Infinite Earths” (Part 1, 2, 3) – Podcast Crossover
Batwoman Podcast Season 1 – Episode 9: “Crisis on Infinite Earths” (Part 1, 2, 3) – Podcast Crossover
December 15, 2019 - 0 comment


Leave a Reply

* fields required